Back to overview
Investigating - Degraded performance
Apr 21, 2026 at 9:32am UTC
Affected services
app.agiltext.com
Resolved
Apr 21, 2026 at 9:32am UTC
Investigating - Degraded performance
Incident status: Monitoring
A fix has been implemented and we are monitoring the results.
Affected services